my.nesi.org.nz not displaying account information
Incident Report for NeSI Status
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 14, 2019 - 09:21 NZST
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jun 14, 2019 - 09:02 NZST
This incident affected: NeSI Accounts.