Freezer.nesi.org.nz system outage

Update

We are continuing to investigate this issue.
Posted Apr 16, 2026 - 08:48 NZST

Investigating

We are currently investigating this issue.
Posted Apr 16, 2026 - 08:48 NZST
This incident affects: Long-term Storage (Freezer).