We have done a rolling restart of NFS services which look to have resolved the user/group resolution issues in OnDemand and the correct mappings are now being displayed
We are now monitoring for any further impact.
If you notice any other problems with OnDemand then please let us know.
Posted Nov 17, 2025 - 17:06 NZDT
Identified
We've identified the underlying cause of the issue and revised down our understanding of the impact. OnDemand apps such as Jupyter are working and able to access user's files consistently with user and group permissions on the main cluster, despite displaying as nobody:nobody. The "NeSI HPC Shell Access" feature is still impacted due to additional ownership checks in SSH, users that need help connecting via SSH can reach out to support.
We are now planning a rolling restart of NFS services later this afternoon which should resolve the user/group resolution issues in OnDemand and result in the correct mappings being displayed.
If you notice any other problems with OnDemand then please let us know.
Posted Nov 17, 2025 - 13:14 NZDT
Investigating
We have encountered an issue with user and group resolution that is currently impacting OnDemand sessions. Users may be experiencing file listing permissions showing as "nobody:nobody" and getting permission denied when trying to read files. This is also impacting the "NeSI HPC Shell Access" feature in OnDemand. Regular/native SSH access to the cluster is not impacted.
Apologies for the Monday disruption, we're investigating workarounds and will provide an update at approx 1pm.