mynesi portal access is down
Incident Report for NeSI Status
Resolved
This incident has been resolved.
Posted 17 days ago. Oct 02, 2019 - 12:44 NZDT
Investigating
We are experiencing issues on Mahuika, currently the mynesi portal is not available
Posted 17 days ago. Oct 02, 2019 - 11:33 NZDT
This incident affected: NeSI Accounts and NeSI Support.