Freezer.nesi.org.nz outage

Monitoring

The Freezer service is again available. We are monitoring and investigating the root cause
Posted Apr 30, 2026 - 10:17 NZST

Investigating

We are currently investigating an issue with Freezer, our long-term storage.
Posted Apr 29, 2026 - 23:05 NZST
This incident affects: Long-term Storage (Freezer).